Cloud Foundry Plugin
  1. Cloud Foundry Plugin
  2. GPCLOUDFOUNDRY-32

App doesn't run with spring-security-core:1.2.7.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: Grails-Cloud-Foundry 1.2.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Mac OS 10.7

      Description

      The Grails application does not start correctly with the latest spring-security-core plugin (1.2.7.1). While it's working fine with a "run-app" in dev mode an deployment to cloudfoundry.com results in following error:

      Class
      .lang.IllegalStateException
      Message
      No thread-bound request found: Are you referring to request attributes outside of an actual web request, or processing a request outside of the originally receiving thread? If you are actually operating within a web request and still receive this message, your code is probably running outside of DispatcherServlet/DispatcherPortlet: In this case, use RequestContextListener or RequestContextFilter to expose the current request.

      Latest spring-security-core and resources plugin where used:

      runtime ":spring-security-core:1.2.7.1"
      runtime ":resources:1.1.6"

      As discussed on the mailling list the last compatible spring-security-core plugin is v1.2.4. After downgrading to this version is also working on cloudfoundry.com

      http://grails.1312388.n4.nabble.com/Problem-with-Cloud-Foundry-Plugin-tp4299226p4316053.html

        Activity

          People

          • Assignee:
            Burt Beckwith
            Reporter:
            David Trattnig
          • Votes:
            5 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: