MongoDB Plugin
  1. MongoDB Plugin
  2. GPMONGODB-190

NullPointerException at org.grails.datastore.mapping.mongo.engine.MongoEntityPersister.checkVersion(MongoEntityPersister.java:571)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0.RC4
    • Fix Version/s: 1.0.0.RC5
    • Labels:
    • Environment:
      Grails 2.0.1, Os X 10.6.8, MongoDB 2.0.3, Java 1.6.0_29
    • Testcase included:
      yes

      Description

      I had this issue in a real project, when storing embedded collections which contained a reference to an object in another collection. The attached integration test demonstrates the problem. However, I have not found any way to show this issue within one test. The integration test has to be run twice , without dropping the db in between. It is not sufficient to just run the test twice within one integration test - it literally has to be run twice. This may seem pretty odd, but this situation seems to occur much more often when using the mongodb plug-in within actual services. To ensure the problem is not related to any problem with the management of documents in mongo, I run the test twice within one integration test. All tests run fine within the first integration test run.

        Activity

        Graeme Rocher added a comment -

        can't reproduce this with the latest code


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            St.H
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: