Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Grails-Neo4j 0.3
    • Labels:
      None
    • Environment:
      JDK 1.6.0_18(Win), JDK1.6.0_20 (Mac Osx 10.6.4), Grails 1.3.1-3, Neo4j plugin 0.2.1

      Description

      Whenever I create a domain class with the grails standard commands and I add a Neo4jEntity annotation to that class I get the following error:

      [groovyc] org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
      [groovyc] C:********\bonzo\grails-app\domain\bonzo\Serie.groovy: -1: Operators === and !== are not supported. Use this.is(that) instead @ line -1, column -1.
      [groovyc] 1 error
      Compilation error: Compilation Failed

      Steps to reproduce:

      • grails create-app bonzo
      • cd bonzo; grails create-domain-class Serie (at this step I get a warning on Neo4jDomainClass.java for unchecked/unsafe operations)
      • edit annotate Serie.groovy with @grails.plugins.neo4j.Neo4jEntity
      • grails compile

        Activity

        Stefan Armbruster added a comment -

        Seems to be Grails 1.3.x related. Does this also occur with Grails 1.2.x?

        Giuseppe Acito added a comment -

        It's correct: changing GRAILS_HOME to a 1.2.x version of Grails will fix this issue.

        A 1.3.x compatible plugin would be a beloved plus.

        Stefan Armbruster added a comment -

        was an issue with Grails 1.3.
        N.B. we'll have to wait for Grails 1.3.4 before doing a release because of http://jira.codehaus.org/browse/GRAILS-6427.


          People

          • Assignee:
            Stefan Armbruster
            Reporter:
            Giuseppe Acito
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: