Remote Pagination Plugin
  1. Remote Pagination Plugin
  2. GPREMOTEPAGINATION-12

Setting the params attribute breaks the pageSizes drop down

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Environment:
      Grails 2.0.1

      Description

      Maybe I'm missing something obvious, but if I include any params in the params attribute, the pageSize drop down list fails to fire an action when I click it.
      For example:
      <util:remotePaginate total="$

      {total}

      "
      action="updateContentList"
      update="contentList"
      pageSizes="[10,20,50,100]"
      max="10"
      model="$

      {[records:records]}

      "
      onLoading="showElement('paginateSpinner');"
      onComplete="hideElement('paginateSpinner');"
      params="$

      {params}

      "
      />
      This will cause the list to break, as will any value for params.

      When a drop down value is clicked, the corresponding action is never called (in my case 'updateContentList'). If I remove the params tag, everything works fine (except that I have no way to send params back to the controller!)

      The paginate buttons do continue to work when using the params parameter; it seems the drop down menu is the only thing affected.

        Activity

        Steffen Gates created issue -
        Amit Jain added a comment -

        Couldn't reproduce the issue. Could you please attach the reproducible sample application.

        Steffen Gates added a comment - - edited

        You're correct, I apologize. It must be some sort of bizarre configuration error in my application. Thanks for your time, you can invalidate the ticket!

        Amit Jain added a comment -

        Closing, as we couldn't reproduce the issue.

        Amit Jain made changes -
        Field Original Value New Value
        Resolution Cannot Reproduce [ 5 ]
        Assignee Amit Jain [ amitjain ]
        Status Open [ 1 ] Resolved [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Steffen Gates
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: