Resources Plugin
  1. Resources Plugin
  2. GPRESOURCES-106

After editing a JavaScript file a few times the resources plugin then reports 404

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.1.2
    • Labels:
    • Environment:
      PCLinuxOS and Windows 7, Grails 2.0RC1, Java 1.6.0_26

      Description

      As stated in the summary then resource plugin can't find the resources even though they're still there.
      The log says:
      resource.ResourceProcessor We can't create resources on the fly unless they are 'ad-hoc', we're going to 404. Resource URI: /js/advanced-form.js
      resource.ResourceTagLib Invocation of <r:resource> for a resource that apparently doesn't exist: /ebulletin/css/normalize.css

      The second line is repeated for every CSS file.
      I've tried to disable the resource plugin but nothing helps.

      I'm forces to restart the application but after a while the same happens again.
      Is it really not possible to "disable" the plugin, so it just behaves like the old resource tag?
      It is kind of brutal to force us to live with the '/static' part in the url's.

        Activity

        Per Gravgaard added a comment -

        Maybe I should mention that I'm using default (out-of-the-box) configuration of the resources plugin

        Marc Palmer added a comment -

        Hi Per,

        I cannot reproduce this currently with the latest (master) code. I fixed a problem with "not found" resources which was definitely causing problems if you refresh the page while grails is reloading the resources.

        As for disabling the plugin - you can force debug mode in config, which is the same thing.

        If you don't want some resources processed at all (/static/ prefixing), just set them in the grails.resources.adhoc.excludes config - see docs.

        Marc Palmer added a comment -

        Can't reproduce with latest 1.1.2 code, and sounds like it was a problem with page refresh during reload.


          People

          • Assignee:
            Marc Palmer
            Reporter:
            Per Gravgaard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: