Resources Plugin
  1. Resources Plugin
  2. GPRESOURCES-218

Major issue with resources plugin which fails to load resources if requested in different order

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 1.2.1
    • Labels:
      None

      Description

      Steps to reproduce:

      • Untar/Unzip the attached grails-resource-issue.tgz file (note that you can achieve the same result by simply issuing grails create-app grails-resource-issue since I did not modify at all the result of this operation!)
      • simple start the app (grails run-app)
      • do not navigate to the app and simply issue in a separate terminal:
        curl -v http://localhost:8080/grails-resource-issue/static/images/spinner.gif
        ...
        < HTTP/1.1 404 Not Found
        < Server: Apache-Coyote/1.1
        < Content-Type: text/html;charset=utf-8
        < Content-Length: 949
        < Date: Mon, 13 May 2013 02:45:51 GMT
        
      • now issue
        curl -v http://localhost:8080/grails-resource-issue/images/spinner.gif
        ...
        < HTTP/1.1 404 Not Found
        < Server: Apache-Coyote/1.1
        < Content-Type: text/html;charset=utf-8
        < Content-Length: 949
        < Date: Mon, 13 May 2013 02:46:01 GMT
        

      => As you can see it is game over... although the image exists, you cannot get it anymore!

      • Now do the following:
      • stop the grails-app and restart it
      • then issue:
        curl -v http://localhost:8080/grails-resource-issue/images/spinner.gif
        ...
        < HTTP/1.1 302 Found
        < Server: Apache-Coyote/1.1
        < X-Grails-Resources-Original-Src: /images/spinner.gif
        < Location: http://localhost:8080/grails-resource-issue/static/images/spinner.gif
        < Content-Length: 0
        < Date: Mon, 13 May 2013 02:46:43 GMT
        
      • and then issue:
        curl -v http://localhost:8080/grails-resource-issue/static/images/spinner.gif
        ...
        < HTTP/1.1 200 OK
        < Server: Apache-Coyote/1.1
        < X-Grails-Resources-Original-Src: /images/spinner.gif
        < Last-Modified: Wed, 15 Feb 2012 03:19:54 GMT
        < Content-Type: image/gif
        < Content-Length: 2037
        < Date: Mon, 13 May 2013 02:46:46 GMT
        

        Activity

        Peter N. Steinmetz added a comment -

        Yes, I suspect though, that this is related to the issue on cached-resources at http://jira.grails.org/browse/GPCACHEDRESOURCES-12 .

        That bug seems to suggest that there is a problem here in resources involved.

        Eli, could you have a look at that bug report and see what you think? This may end up being a tricky one to test.

        Eli Israel added a comment -

        I'd say what we're seeing here is actually just a duplication of http://jira.grails.org/browse/GPCACHEDRESOURCES-11

        Peter N. Steinmetz added a comment -

        OK, so it looks like that has a workaround, and should really be an issue for cached-resources. It looks like Graeme Rocher may be the current primary lead on that plugin (see https://github.com/grails-plugins/grails-cached-resources).

        If all right with you, since the initial error report appears to have been fixed, I will close this particular issue.

        Peter N. Steinmetz added a comment -

        This bug no longer appears reproducible per the initial report. GPCACHEDRESOURCES-11 appears similar when cached resources is in use.

        Eli Israel added a comment -

        Yes, I'd agree. Looks like cached resources needs some TLC.


          People

          • Assignee:
            Peter N. Steinmetz
            Reporter:
            Yan Pujante
          • Votes:
            2 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: