Shiro Plugin
  1. Shiro Plugin
  2. GPSHIRO-65

Using shiro plugin and birt report plugin, there is conflict

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Grails 1.3.7,shiro 1.1.3, birt report 3.7.0.1

      Description

      In my Grails app, I install shiro plugin and birt report plugin.When run-app, there is an error:
      [groovyc] Compile error during compilation with javac.
      [groovyc] C:\Documents and Settings\Administrator\.grails\1.3.7\projects\test\
      plugins\shiro-1.1.3\src\java\org\apache\shiro\grails\SavedHttpServletRequest.jav
      a:54:
      [groovyc] copy(javax.servlet.ServletInputStream,java.io.ByteAr
      rayOutputStream)
      [groovyc] org.apache.commons.io.IOUtils
      [groovyc] IOUtils.copy(request.getInputStream(), output);
      [groovyc] ^
      [groovyc] Note: the code uses unchecked or unsafe operations.
      Note: Recompile with -Xlint:unchecked for details.

        Activity

        Hide
        Peter Ledbrook added a comment -

        Try upgrading to version 1.2.0-SNAPSHOT of the Shiro plugin. That seems to work with the BIRT Report plugin.

        Show
        Peter Ledbrook added a comment - Try upgrading to version 1.2.0-SNAPSHOT of the Shiro plugin. That seems to work with the BIRT Report plugin.

          People

          • Assignee:
            Peter McNeil
            Reporter:
            hu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated: