Spring Security Core Plugin
  1. Spring Security Core Plugin
  2. GPSPRINGSECURITYCORE-26

Spring Security Core and UI conflict over jquery version?

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      ubuntu 10.x,
      grails 1.3.3
      spring-security-core & ui: latest

      Description

      When I added spring-security-ui (to get add/remove users and such), it installed jquery 1.4.2.5 (along with related jquery-ui).

      On compile or run-app, I get a (grails) message asking if I want to 'upgrade' from 1.4.2.5 to 1.4.2.4. I finally agreed to upgrade/downgrade, and now I get the following error messages:

      Dependencies resolved in 855ms.
      Running script /usr/local/grails/scripts/RunApp.groovy
      Environment set to development
      [groovyc] Compiling 1 source file to /home/sean/.grails/1.3.3/projects/sdrprep/plugin-classes
      [native2ascii] Warning: messages.properties modified in the future.
      [native2ascii] Converting 1 file from /home/sean/.grails/1.3.3/projects/sdrprep/plugins/jquery-ui-1.8.4/grails-app/i18n to /home/sean/.grails/1.3.3/projects/sdrprep/resources/plugins/jquery-ui-1.8.4/grails-app/i18n
      Error: The following plugins failed to load due to missing dependencies: [springSecurityUi]

      • Plugin: springSecurityUi, Dependencies: [springSecurityCore, mail, jquery, jqueryUi, famfamfam]

      and my plugin list is:

      Plugins available in the grailsCore repository are listed below:
      -------------------------------------------------------------

      dummy <> –
      hibernate <1.3.4> – Hibernate for Grails
      tomcat <1.3.4> – Apache Tomcat plugin for Grails
      webflow <1.3.4> – Spring Web Flow Plugin

      Plug-ins you currently have installed are listed below:
      -------------------------------------------------------------

      bubbling 2.1.2 – Bubbling Library YUI Extension
      famfamfam 1.0.1 – Silk icons from famfamfam.com
      grails-ui 1.2-SNAPSHOT – Grails UI
      hibernate 1.3.3 – Hibernate for Grails
      jquery 1.4.2.4 – JQuery for Grails
      jquery-ui 1.8.4 – jQuery UI resources
      mail 0.9 – Provides Mail support to a running Grails application
      spring-security-core1.0.1 – Spring Security Core Plugin
      spring-security-ui 0.1.1 – User interface extensions for the Spring Security plugin.
      tomcat 1.3.3 – Apache Tomcat plugin for Grails
      webflow 1.3.1 – Spring Web Flow Plugin
      yui 2.7.0.1 – Yahoo! User Interface Library (YUI)

      I assume the problem is a conflict in the jquery version required?
      Thanks,

      Sean

        Activity

        Hide
        Bob Pawlowski added a comment -

        I'm having the same issue. Is there a workaround?

        Show
        Bob Pawlowski added a comment - I'm having the same issue. Is there a workaround?
        Hide
        Burt Beckwith added a comment -

        Upgrade to 1.4.2.5. The only difference between 1.4.2.4 and 1.4.2.5 is that .5 has a fix to specify that it works with Grails 1.2.2 and higher. 1.4.2.4 had a bug where it would only install in 1.3.3+ apps.

        Show
        Burt Beckwith added a comment - Upgrade to 1.4.2.5. The only difference between 1.4.2.4 and 1.4.2.5 is that .5 has a fix to specify that it works with Grails 1.2.2 and higher. 1.4.2.4 had a bug where it would only install in 1.3.3+ apps.
        Hide
        Masatoshi Hayashi added a comment - - edited

        I think this issue has the cause in the dependency settings of jQueryUI plugin.

        In "dependencies.groovy" of jQueryUI plugin, "jquery 1.4.2.4" is included in the runtime dependence.
        So I think it works if you remove the reference to "jquery 1.4.2.4" from the "dependencies.groovy" file.

        Reference:
        http://jira.codehaus.org/browse/GRAILSPLUGINS-2402

        Show
        Masatoshi Hayashi added a comment - - edited I think this issue has the cause in the dependency settings of jQueryUI plugin. In "dependencies.groovy" of jQueryUI plugin, "jquery 1.4.2.4" is included in the runtime dependence. So I think it works if you remove the reference to "jquery 1.4.2.4" from the "dependencies.groovy" file. Reference: http://jira.codehaus.org/browse/GRAILSPLUGINS-2402
        Hide
        Burt Beckwith added a comment -

        This is a problem with the jQuery UI plugin: GRAILSPLUGINS-2402

        Show
        Burt Beckwith added a comment - This is a problem with the jQuery UI plugin: GRAILSPLUGINS-2402
        Hide
        Bob Pawlowski added a comment -

        Thanks. Removing the reference to jquery 1.4.2.4 worked.

        Show
        Bob Pawlowski added a comment - Thanks. Removing the reference to jquery 1.4.2.4 worked.

          People

          • Assignee:
            Burt Beckwith
            Reporter:
            Sean OC
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: