Spring Security UI Plugin
  1. Spring Security UI Plugin
  2. GPSPRINGSECURITYUI-23

Spring-Security-UI plugins does not work with MongoDB plugin

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Grails-Spring-Security-UI 0.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Ubuntu ,STS - 2.7.1,

      Description

      Using MongoDB as the datasource with Spring security ui seems not fit well. To make this work I just made a tweak in SpringSecurityUiService class -> static transactional = 'mongo'

        Activity

        Hide
        Prasanth added a comment -
        • STS version is 2.6.1
        Show
        Prasanth added a comment - STS version is 2.6.1
        Hide
        Burt Beckwith added a comment -

        There's more to it than that - several queries use HQL which isn't supported in any of the NoSQL plugins.

        Show
        Burt Beckwith added a comment - There's more to it than that - several queries use HQL which isn't supported in any of the NoSQL plugins.

          People

          • Assignee:
            Burt Beckwith
            Reporter:
            Prasanth
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: