WebXML Plugin
  1. WebXML Plugin
  2. GPWEBXML-6

WebXML reorders default filters, this breaks UTF-8 POST requests

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Grails-Web-Xml 1.5
    • Labels:
      None

      Description

      In default web.xml there is charEncodingFilter filter-mapping on the first place. WebXML config places it after hiddenHttpMethod filter. HiddenHttpMethod filter uses getParameter() method before request.setEncoding() method was called. This causes all UTF-8 characters in request parameters are incorrectly handled.
      I suppose that this behavior is caused by findFilterMappingNames method in _Events.groovy script (in scripts directory). This method uses Set instead of List, to store filter-mappings.

        Activity


          People

          • Assignee:
            Burt Beckwith
            Reporter:
            Michal Kurtak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: