Grails
  1. Grails
  2. GRAILS-3776

Some default codecs are not initiated during application launching

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta2
    • Fix Version/s: 1.1-beta3
    • Component/s: Plugins
    • Labels:
      None
    • Environment:
      Windows 2000

      Description

      There are some new codecs added in Grails 1.1 (such as, SHA1Codec, MD5Codec, etc.), but they won't be initiated at all during application launching.
      After a quick tracing, seems like these new codecs aren't included in the providedArtefacts declaration in org.codehaus.groovy.grails.plugins.CodecsGrailsPlugin.

        Activity

        Hide
        Marc Palmer added a comment -

        Just giving the kudos back - didn't notice it was closed! Was going to do it, as was my bad

        Show
        Marc Palmer added a comment - Just giving the kudos back - didn't notice it was closed! Was going to do it, as was my bad
        Hide
        Graeme Rocher added a comment -

        Bulk closing bunch of resolved issues

        Show
        Graeme Rocher added a comment - Bulk closing bunch of resolved issues
        Hide
        Fabian Gebert added a comment -

        still not fixed in 1.3.7

        Show
        Fabian Gebert added a comment - still not fixed in 1.3.7
        Hide
        Peter Ledbrook added a comment -

        What's not fixed?

        Show
        Peter Ledbrook added a comment - What's not fixed?
        Hide
        Fabian Gebert added a comment -

        encodeAsMD5 doesn't work

        Show
        Fabian Gebert added a comment - encodeAsMD5 doesn't work
        Hide
        Peter Ledbrook added a comment -

        I've just tested with a simple Grails 1.3.7 application and it works fine. If you have a particular use case in which it doesn't work, please attach a reproducible example to a new issue.

        Show
        Peter Ledbrook added a comment - I've just tested with a simple Grails 1.3.7 application and it works fine. If you have a particular use case in which it doesn't work, please attach a reproducible example to a new issue.

          People

          • Assignee:
            Peter Ledbrook
            Reporter:
            kenwei
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development