Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Not A Bug
    • Affects Version/s: 1.1-beta2
    • Fix Version/s: 1.1-RC1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP

      Description

      Calling Campaign.list() on the following domain class under 1.04 worked fine, however, in 1.1-beta2 it returns a list of nulls.

      class Campaign {

      Long id
      String key
      String name
      String description

      static mapping = {
      table 'ca_campaign'
      version false
      columns

      { id column:'campaign_id' }

      id generator:'sequence', params:[sequence:'ca_campaign_campaign_id_seq']
      }

      }

        Activity

        Peter Ledbrook added a comment -

        Note that your mapping is incorrect. You should not have multiple "id" entries. The mapping should be:

        static mapping = {
            table 'ca_campaign'
            version false
            id column:'campaign_id', generator:'sequence', params:[sequence:'ca_campaign_campaign_id_seq']
        }
        

        With this change, I cannot reproduce your problem with beta3.

        Andrew Zielinski added a comment -

        Thanks.

        Should an appropriate exception be thrown if that is the case?


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Andrew Zielinski
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development