Grails
  1. Grails
  2. GRAILS-5253

Upgrade does not reference java source files outside of the grails app

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 1.2-M3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux 2.6.28-16-generic #55-Ubuntu SMP Tue Oct 20 19:48:32 UTC 2009 x86_64 GNU/Linux

      Description

      SCENARIO
      -----------------------------------------------
      I have a grails app, FooApp, based on grails 1.1-RC2.
      I have a set of libs in a separate path, com.foo.bar.
      FooApp references class files in com.foo.bar.

      REPRO (upgrading from 1.1-RC2 to 1.2-M3 )
      -----------------------------------------------
      ./FooApp$ grails clean
      ./FooApp$ grails upgrade

      ERROR
      -----------------------------------------------
      Grails upgrade is "unable to resolve" classes outside the grails app directory.

      OUTPUT
      -----------------------------------------------
      Resolving dependencies...
      Dependencies resolved in 1289ms.
      Running script .../grails-1.2-M3/scripts/Upgrade.groovy
      Environment set to development
      NOTE: Your application currently expects grails version [1.1-RC2], this target will upgrade it to Grails 1.2-M3 ...

      WARNING: This target will upgrade an older Grails application to 1.2-M3.
      However, tag libraries provided by earlier versions of Grails found in grails-app/taglib will be removed.
      The target will not, however, delete tag libraries developed by yourself.
      Are you sure you want to continue?
      (y, n)
      y
      [delete] Deleting directory /FooApp/resources
      Error executing script Upgrade: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed, script1256237510929.groovy: 1: unable to resolve class com.foo.Bar
      @ line 1, column 1.
      1 error

      gant.TargetExecutionException: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed, script1256237510929.groovy: 1: unable to resolve class com.foo.Bar
      @ line 1, column 1.
      1 error

      at gant.Gant$_dispatch_closure4.doCall(Gant.groovy:331)
      at gant.Gant$_dispatch_closure6.doCall(Gant.groovy:334)
      at gant.Gant$_dispatch_closure6.doCall(Gant.groovy)
      at gant.Gant.withBuildListeners(Gant.groovy:344)
      at gant.Gant.this$2$withBuildListeners(Gant.groovy)
      at gant.Gant$this$2$withBuildListeners.callCurrent(Unknown Source)
      at gant.Gant.dispatch(Gant.groovy:334)
      at gant.Gant.this$2$dispatch(Gant.groovy)
      at gant.Gant.invokeMethod(Gant.groovy)
      at gant.Gant.processTargets(Gant.groovy:495)
      at gant.Gant.processTargets(Gant.groovy:480)
      Caused by: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed, script1256237510929.groovy: 1: unable to resolve class com.foo.Bar
      @ line 1, column 1.
      1 error

        Issue Links

          Activity

          Graeme Rocher added a comment -

          Please attach an example that reproduces the issue. Thank you.

          Todd Greenwood added a comment -

          Once I get beyond http://jira.codehaus.org/browse/GRAILS-3439, then I'd be happy to provide a repro. However, I suspect these are similar issues. However, 3439 deals w/ referencing external jars and class files, and this issue is about referencing external source (.java) files.

          Jeff Scott Brown added a comment -

          The upgrade script functionality will be removed soon as part of GRAILS-10744.


            People

            • Assignee:
              Unassigned
              Reporter:
              Todd Greenwood
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Last Reviewed:

                Development