Grails
  1. Grails
  2. GRAILS-5949

Disable ehcache's "phone home" code that is turned on by default and spy's on production environments

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.2 final, 1.2.1
    • Fix Version/s: 1.2.2, 1.3-M1
    • Component/s: None
    • Labels:
      None

      Activity

      Graeme Rocher added a comment -

      Don't really like hard coding this into Grails, but I see no other way. Fixed:

      http://github.com/grails/grails-core/commit/d94300a4c8285443a920d070fd8bf8760ed2e7b9

      Burt Beckwith added a comment -
      Ingo Wiarda added a comment -

      I just ran a test with

      grails test-app

      and saw:
      net.sf.ehcache.util.UpdateChecker New update(s) found: 2.4.7 http://www.terracotta.org/confluence/display/release/Release+Notes+Ehcache+Core+2.4. Please check http://ehcache.org for the latest version.

      looks like there was a regression.

      Burt Beckwith added a comment -

      Ingo - this is actually a separate problem. See GRAILS-8897


        People

        • Assignee:
          Graeme Rocher
          Reporter:
          Marc Palmer
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development