Grails
  1. Grails
  2. GRAILS-6428

list-plugins doesn't work outside project directory

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.3.2
    • Fix Version/s: None
    • Component/s: Plugins
    • Labels:
      None
    • Flagged:
      Impediment

      Description

      In grails 1.2.2, you could run grails list-plugins in any directory and obtain the list of plugins in the default repository. This is no longer the case in a fresh installation because the grailsCentral() repository is not hardcoded in the scripts.

      The output in this case looks like this:

      Welcome to Grails 1.3.2 - http://grails.org/
      Licensed under Apache Standard License 2.0
      Grails home is set to: /opt/grails-1.3.2

      Base Directory: /home/luis
      Resolving dependencies...
      Dependencies resolved in 970ms.
      Running script /opt/grails-1.3.2/scripts/ListPlugins_.groovy
      Environment set to development

      Plug-ins you currently have installed are listed below:
      -------------------------------------------------------------

      You do not have any plugins installed.

      To find more info about plugin type 'grails plugin-info [NAME]'

      To install type 'grails install-plugin [NAME] [VERSION]'

      For further info visit http://grails.org/Plugins

        Issue Links

          Activity

          Bobby Warner added a comment -

          I don't think this is a bug. In fact, I think it's good the it works now because you wouldn't want to have the central repo hardcoded so that you can list plugins from your own custom repositories. I recommend closing this issue. Thanks, Bobby

          Peter Ledbrook added a comment -

          I disagree. From a user perspective it makes no sense that you need to be in a project in order to interrogate the public plugin repository. In fact, I would argue that you should be able to define plugin repositories in ~/.grails/settings.groovy, all of which would be interrogated by the list-plugins command when run outside of a project.

          Bobby Warner added a comment -

          This issue is a duplicate of GRAILS-6699. Closing this one as the other one also includes "plugin-info" in addition to "list-plugins" needed to fix.


            People

            • Assignee:
              Bobby Warner
              Reporter:
              Luis Arias
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Last Reviewed:

                Development