Grails
  1. Grails
  2. GRAILS-6582

CLONE -Grails 1.2.2 do not works on IBM JDK5

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 1.2.2
    • Fix Version/s: 1.2.3, 1.3.2
    • Component/s: Project infrastructure
    • Labels:
      None
    • Environment:
      Windows XP, IBM JDK 5.0

      Description

      After updating Grails from 1.2.2 from 1.2.1 it fails to run on IBM JDK 5.0

      C:\grails-1.2.2\bin>grails.bat
      Error starting Grails: org.apache.tools.ant.Project
      java.lang.NoClassDefFoundError: org.apache.tools.ant.Project
      at java.lang.J9VMInternals.verifyImpl(Native Method)
      at java.lang.J9VMInternals.verify(J9VMInternals.java:69)
      at java.lang.J9VMInternals.initialize(J9VMInternals.java:131)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:79)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:618)
      at org.codehaus.groovy.grails.cli.support.GrailsStarter.rootLoader(Grail
      sStarter.java:215)
      at org.codehaus.groovy.grails.cli.support.GrailsStarter.main(GrailsStart
      er.java:240)
      Caused by: java.lang.ClassNotFoundException: org.apache.tools.ant.Project
      at org.codehaus.groovy.tools.RootLoader.findClass(RootLoader.java:156)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:631)
      at org.codehaus.groovy.tools.RootLoader.loadClass(RootLoader.java:128)
      at org.codehaus.groovy.grails.cli.support.GrailsRootLoader.loadClass(Gra
      ilsRootLoader.java:43)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:597)
      ... 9 more

      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build pwi32dev-20090707 (SR10
      ))
      IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223-2009070
      7 (JIT enabled)

      Changing Java to JDK 1.6.0.18 fixed problem, but Grails 1.2.X should run on JDK 1.5. I suspect that some Grails classes were build by Java6 builder tools by mistake.

        Activity

        Hide
        Scott Doyle added a comment -

        I am encountering the same issues within the Springsource Tool Suite IDE when trying to run the application when the project build path is directed to the Websphere Application Server's 1.5 JDK. I do not encounter the error when running against the standard Java JDK 1.5.0_22.

        I tried to change the groovy-starter.conf file located in \grails-1.2.2\conf\ under the STS installation directory as suggested in http://jira.codehaus.org/browse/GRAILS-6097 but without success.

        Any suggestions would be appreciated.

        Show
        Scott Doyle added a comment - I am encountering the same issues within the Springsource Tool Suite IDE when trying to run the application when the project build path is directed to the Websphere Application Server's 1.5 JDK. I do not encounter the error when running against the standard Java JDK 1.5.0_22. I tried to change the groovy-starter.conf file located in \grails-1.2.2\conf\ under the STS installation directory as suggested in http://jira.codehaus.org/browse/GRAILS-6097 but without success. Any suggestions would be appreciated.
        Hide
        Burt Beckwith added a comment -

        Why the clone? Is it not working?

        Show
        Burt Beckwith added a comment - Why the clone? Is it not working?
        Hide
        Scott Doyle added a comment -

        No, I am using STS 2.3.2 and when I change the Java Build Path for the project to point to the IBM WAS 6.1 JRE I encounter the following error when trying to run the application:

        java.lang.NoClassDefFoundError: org.apache.tools.ant.Project
        at java.lang.J9VMInternals.verifyImpl(Native Method)
        at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
        at java.lang.J9VMInternals.initialize(J9VMInternals.java:127)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:615)
        at org.codehaus.groovy.grails.cli.support.GrailsStarter.rootLoader(GrailsStarter.java:215)
        at org.codehaus.groovy.grails.cli.support.GrailsStarter.main(GrailsStarter.java:240)
        Error starting Grails: org.apache.tools.ant.Project

        I tried changing the groovy-starter.conf file located in the Grails directory installed under the STS directory structure as suggested by the original JIRA log but it did not resolve the error. Unfortunately, my applications need to run on WAS which is why I need to compile against their JRE v1.5 rather than use JDK 1.6.

        Show
        Scott Doyle added a comment - No, I am using STS 2.3.2 and when I change the Java Build Path for the project to point to the IBM WAS 6.1 JRE I encounter the following error when trying to run the application: java.lang.NoClassDefFoundError: org.apache.tools.ant.Project at java.lang.J9VMInternals.verifyImpl(Native Method) at java.lang.J9VMInternals.verify(J9VMInternals.java:66) at java.lang.J9VMInternals.initialize(J9VMInternals.java:127) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:615) at org.codehaus.groovy.grails.cli.support.GrailsStarter.rootLoader(GrailsStarter.java:215) at org.codehaus.groovy.grails.cli.support.GrailsStarter.main(GrailsStarter.java:240) Error starting Grails: org.apache.tools.ant.Project I tried changing the groovy-starter.conf file located in the Grails directory installed under the STS directory structure as suggested by the original JIRA log but it did not resolve the error. Unfortunately, my applications need to run on WAS which is why I need to compile against their JRE v1.5 rather than use JDK 1.6.
        Hide
        Graeme Rocher added a comment -

        old / invalid

        Show
        Graeme Rocher added a comment - old / invalid

          People

          • Assignee:
            Burt Beckwith
            Reporter:
            Scott Doyle
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Last Reviewed:

              Development