Grails
  1. Grails
  2. GRAILS-6765

Classifier does not work in dependency DSL

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.3.4
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      It seems that the classifier is ignored in dependency declarations. The attached project has:

      dependencies {
          build "commons-io:commons-io:1.4:sources"
          build group: "commons-lang", name: "commons-lang", version: "2.4", classifier: "sources"
      }
      

      but neither of the syntaxes work. If you unpack the zip file (create a project directory to unpack it to first) and run grails compile, you'll see in the output that the first syntax is invalid and the second does not result in the '-sources' JAR being downloaded.

        Issue Links

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Luke Daley
              Reporter:
              Peter Ledbrook
            • Votes:
              4 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development