Grails
  1. Grails
  2. GRAILS-7954

Error while running integration tests

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-M1
    • Fix Version/s: 2.0-M2
    • Component/s: Testing
    • Labels:
      None
    • Environment:
      Grails 2.0.0.SNAPSHOT(Build-1233)
    • Testcase included:
      yes

      Description

      |  org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'org.codehaus.groovy.grails.context.support.PluginAwareResourceBundleMessageSource' to required type 'org.springframework.context.support.StaticMessageSource' for property 'messageSource'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [org.codehaus.groovy.grails.context.support.PluginAwareResourceBundleMessageSource] to required type [org.springframework.context.support.StaticMessageSource] for property 'messageSource': no matching editors or conversion strategy found
      	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:76)
      	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
      	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
      	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
      	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
      	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
      	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
      	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
      	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:31)
      	at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
      	at org.junit.runners.Suite.runChild(Suite.java:128)
      	at org.junit.runners.Suite.runChild(Suite.java:24)
      	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193)
      	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52)
      	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191)
      	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42)
      	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184)
      	at org.junit.runners.ParentRunner.run(ParentRunner.java:236)
      	at _GrailsTest_groovy$_run_closure4.doCall(_GrailsTest_groovy:285)
      	at _GrailsTest_groovy$_run_closure2.doCall(_GrailsTest_groovy:243)
      	at _GrailsTest_groovy$_run_closure1_closure21.doCall(_GrailsTest_groovy:190)
      	at _GrailsTest_groovy$_run_closure1.doCall(_GrailsTest_groovy:179)
      	at TestApp$_run_closure1.doCall(TestApp.groovy:82)
      Caused by: java.lang.IllegalStateException: Cannot convert value of type [org.codehaus.groovy.grails.context.support.PluginAwareResourceBundleMessageSource] to required type [org.springframework.context.support.StaticMessageSource] for property 'messageSource': no matching editors or conversion strategy found
      	... 23 more
      

        Activity

        Raviteja added a comment -

        Same is the case with 2.0 M1

        Edvinas Bartkus added a comment -

        I can confirm that the issue is still present in 2.0.0.BUILD-SNAPSHOT 2011-08-23
        The issue happens only for the integration tests that the name matches domain classes (no problems with controller or service tests). For example:
        Domain - org.grails.Project
        Test - org.grails.ProjectTests


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Raviteja
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development