Grails
  1. Grails
  2. GRAILS-8288

NPE exception thrown on accessing default page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-RC2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 7, jdk 1.6.0_27, grails 2.0.0.BUILD-SNAPSHOT, build 1571

      Description

      With build 1571, after creating and running a clean new app, NPE is thrown on accessing a default application's page. With build 1566 everything is working fine.

      Steps to reproduce:

      grails create-app someapp
      cd someapp
      grails compile
      grails run-app

      Invoking http://localhost:8080/someapp throws NPE.

      Output from console:

      grails run-app
      | Server running. Browse to http://localhost:8080/someapp
      | Error 2011-11-10 22:38:07,000 ["http-bio-8080"-exec-1] ERROR [/someapp].[gsp]  - Servlet.service() for servlet [gsp] in context with path [/someapp] threw exception
      Message: Error mapping onto view [/index]: null
         Line | Method
      ->>  26 | doFilter in org.grails.plugin.resource.DevModeSanityFilter
      - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
      |   886 | runTask  in java.util.concurrent.ThreadPoolExecutor$Worker
      |   908 | run . .  in     ''
      ^   662 | run      in java.lang.Thread
      
      Caused by NullPointerException: null
      ->>  26 | doFilter in org.grails.plugin.resource.DevModeSanityFilter
      - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
      |   886 | runTask  in java.util.concurrent.ThreadPoolExecutor$Worker
      |   908 | run . .  in     ''
      ^   662 | run      in java.lang.Thread

        Activity

        Graeme Rocher added a comment -

        Windows only bug - Thanks for the reports !


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Damir Murat
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development