Grails
  1. Grails
  2. GRAILS-8332

Missing Method trying to launch Build 1593 in tomcat6 on windows

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Not A Bug
    • Affects Version/s: 2.0-RC2
    • Fix Version/s: 2.0-RC2
    • Component/s: ContinuousBuild
    • Labels:
      None
    • Environment:
      Windows 7 - Tomcat6

      Description

      I ran into the gsp parsing bugs in RC1. So I'm trying the latest stable build. When I run my app in Intellij it appears to work, but when I try to put the war file directly into tomcat and initialize tomcat, I get the below error. It appears to have the asm3.1.jar file in the WEB-INF.lib directory. I don't have any idea what is happening unfortunately.

      org.objectweb.asm.ClassWriter.<init>(Z)V
      java.lang.NoSuchMethodError: org.objectweb.asm.ClassWriter.<init>(Z)V
      at org.codehaus.groovy.runtime.callsite.CallSiteGenerator.compileStaticMethod(CallSiteGenerator.java:231)
      at org.codehaus.groovy.reflection.CachedMethod.createStaticMetaMethodSite(CachedMethod.java:264)
      at org.codehaus.groovy.runtime.callsite.StaticMetaMethodSite.createStaticMetaMethodSite(StaticMetaMethodSite.java:111)
      at groovy.lang.MetaClassImpl.createStaticSite(MetaClassImpl.java:2993)
      at org.codehaus.groovy.runtime.callsite.CallSiteArray.createCallStaticSite(CallSiteArray.java:59)
      at org.codehaus.groovy.runtime.callsite.CallSiteArray.createCallSite(CallSiteArray.java:144)
      at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:40)
      at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:117)
      at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:125)
      at org.codehaus.groovy.grails.commons.cfg.ConfigurationHelper.<clinit>(ConfigurationHelper.groovy:38)
      at org.codehaus.groovy.grails.commons.DefaultGrailsApplication.getConfig(DefaultGrailsApplication.java:372)
      at org.codehaus.groovy.grails.plugins.log4j.web.util.Log4jConfigListener.contextInitialized(Log4jConfigListener.java:47)
      at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4135)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4630)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
      at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1041)
      at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:964)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
      at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
      at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
      at org.apache.catalina.core.StandardService.start(StandardService.java:519)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)

        Activity

        Graeme Rocher added a comment -

        Can't reproduce this, but it seems your application is pulling in an older version of groovy since Grails uses "groovy-all" which has a jarjar'ed version of ASM 3.3, whilst the stacktrace indicates that "groovy-all" is not being used hence the ASM conflict. Take a look at your "dependency-report" and see whether your application is pulling in another Groovy jar

        Andrew Ressler added a comment -

        Hello Graeme,
        I believe you are right. I was having a problem using M2 and yesterday I traced that to a statement

        compile ('org.codehaus.groovy.modules.http-builder:http-builder:0.5.0-RC2') which was indeed trying to load an old version of groovy. So that was likely the same problem trying to use the latest build.
        Please close the bug.
        Thank you, Andrew

        Graeme Rocher added a comment -

        Thanks for confirming


          People

          • Assignee:
            Unassigned
            Reporter:
            Andrew Ressler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development