Grails
  1. Grails
  2. GRAILS-8376

nullable: true on superclass association is not respected in mocked child class

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-RC1
    • Fix Version/s: 2.0 final
    • Component/s: Testing
    • Labels:
      None
    • Testcase included:
      yes

      Description

      If I have a parent class with an association that is marked nullable: true saving a mock child instance fails if the association is null. Regular property constraints seem to be inherited correctly the problem is only exhibited on associations. See attached project.

        Activity

        Graeme Rocher added a comment -

        this test passes in HEAD


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Robert Fletcher
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development