Grails
  1. Grails
  2. GRAILS-8386

Errors while launching application

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0-RC2
    • Fix Version/s: 2.0-RC3
    • Component/s: Persistence
    • Labels:
    • Environment:
      Ubuntu x64, Oracle Java 1.6

      Description

      I can't run application after upgrading to RC2. Everything works fine on RC1, so it shouldn't be an issue with my code. Stacktrace, related class and application.properties in attachment.

      1. application.properties
        0.4 kB
        Krzysztof Cygan
      2. Place.groovy
        5 kB
        Krzysztof Cygan
      3. stacktrace.log
        4 kB
        Krzysztof Cygan

        Activity

        Burt Beckwith added a comment -

        Looks like "Caused by PropertyNotFoundException: Could not find a setter for property attached in class pl.tutejszy.business.Address" is the culprit

        Krzysztof Cygan added a comment -

        Yep, seems so, but why it happens only on RC2? I have cleaned the whole ~/.grails directory as well as cleaned the application with grails clean.

        Downgraded the same code to RC1 and works fine. Seems to me like a bug with embedded mapping, but I might be wrong.

        Graeme Rocher added a comment -

        Try adding

        static transients = ['attached']
        

        To your domain class

        Krzysztof Cygan added a comment - - edited

        The line above fixes this, thanks


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Krzysztof Cygan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development