Grails
  1. Grails
  2. GRAILS-8540

Interactive mode should exit on Ctrl-D

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1-RC1
    • Component/s: None
    • Labels:
      None

      Description

      Shells usually allow you to escape by issuing END_OF_TRANSMISSION as ctrl-d.
      It is also helpful if the shell tells you that it's exiting.

        Activity

        Raviteja added a comment -

        I'd say it's a duplicate of GRAILS-8076. It's already scheduled for 2.0.1.

        Marco Vermeulen added a comment -

        A fix for this in a pull request:
        https://github.com/grails/grails-core/pull/145

        Burt Beckwith added a comment -

        Thanks for the pull request.

        Christoph Neuroth added a comment -

        This does not work with Grails 2.0.1 on OSX, Ctrl-D causes:
        grails> | Error Error running script null: Cannot invoke method trim() on null object (Use --stacktrace to see the full trace)

        Marco Vermeulen added a comment -

        This is the old behaviour that I fixed.

        I don't think my changes made it into 2.0.1 because it was a maintenance release.
        We will probably need to wait for 2.1.0?


          People

          • Assignee:
            Burt Beckwith
            Reporter:
            Marco Vermeulen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development