Grails
  1. Grails
  2. GRAILS-8628

Grails 2.0 basic warfile doesn't run on Weblogic 10.2

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 2.0 final
    • Fix Version/s: 2.0.4
    • Component/s: Build System
    • Environment:
      $ uname -a
      Linux lxdnd968 2.6.9-101.ELsmp #1 SMP Fri May 27 18:56:38 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
      $ which java
      /prod/appl/bea/home10.2/jrockit_150_17/bin/java

      Description

      Created a basic 2.0 grails app in spring source tool suite 2.8.1 with grails and groovy plugins. Configured for grails home 2.0.0 and groovy 1.8.3. Using JDK 1.6 with compatibility set to 1.5.
      War creates fine - but then 2 issues when I go to deploy on weblogic.
      1. War Doesn't include the needed standard.jar but I think there's another Jira on this.

      • Added this using a copy command in buildconfig.groovy.
        2. Get exceptions trying to create the pluginManager from applicationContext.xml.
      • Not the same problem as reported for weblogic 10.3 in previous version of Grails... I followed the suggestions to create a weblogic.xml file with context root, rename sessionid cookie, and specify prefer-webinf-classes. Same issue. Log file attached.

        Issue Links

          Activity

          Lari Hotari added a comment -

          Is your "home page" a GSP called grails-app/views/index.gsp ? In Grails 2.0 there was a change that you cannot access GSPs under grails-app/views directly any more (GRAILS-7542). If that's the case, you can move the index.gsp GSP to the web-app directory.

          There seems to be a Jira issue about this problem already: GRAILS-8767 . I'm not sure if it's a real problem or just caused by the GRAILS-7542 change.

          Lari Hotari added a comment -

          Daniel, there is a workaround for your problem.

          Daniel Chapman added a comment -

          Sorry to have all the issues... Still pretty new regarding the magic parts
          The workaround worked for the default index.gsp, How do I get the rest of the index actions to work?

          One interesting thing to note is that where I don't define anything in the controller for index, it works, and where I have a redirect or something - it doesn't work:

          Doesn't work:
          CmsEnvController:
          def index =

          { log.debug("index") //Doesn't print redirect(action: "list", params: params) }

          Does work:
          DonwloadsController:
          def index =

          { //nothing, default to index.gsp }

          I'll attach the log output for when I click on the CmsEnvController from the home page (which goes to index).

          Daniel Chapman added a comment -

          Can't attach - probably because this issue has been closed.....

          Daniel Chapman added a comment -

          in CmsEnvController above, there's a carriage return after "//Doesnt' print".
          The next linke would be a redirect.

          So I'm not noticing that this controller method gets called at all when I go to index url.


            People

            • Assignee:
              Burt Beckwith
              Reporter:
              Daniel Chapman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Last Reviewed:

                Development