Grails
  1. Grails
  2. GRAILS-8690

Unit test side-effects in interactive console

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.1
    • Component/s: None
    • Labels:
      None

      Description

      Unit tests with GORM are leaking into each other. To reproduce, grab the unit-test-bug-2 branch of the grails-website project, start the interactive console, and then run

      test-app unit: UserService
      

      three (3) times. The first time, the tests pass. The second time, 2 out of 3 fail. The last time, all of the tests fail.

        Activity

        Graeme Rocher added a comment -

        Seems to work fine in the current master branch. Probably a duplicate of GRAILS-8530


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Peter Ledbrook
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development