Grails
  1. Grails
  2. GRAILS-8697

Dynamic scaffolding has problem with custom 'index' action

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0 final
    • Fix Version/s: 2.0.1
    • Component/s: Scaffolding
    • Labels:
      None

      Description

      I just tried to upgrade the grails-pomodoro project to Grails 2 and discovered this bug. Running the app and then hitting the http://locahost:8080/PomodoroApp/task/index URL causes an exceptino to be thrown in the background:

      | Error 2012-01-30 10:12:01,881 ["http-bio-8080"-exec-1] ERROR view.ScaffoldingViewResolver  - Error generating scaffolded view [/layouts/task/index]: /Users/pledbrook/dev/tools/grails-core/grails-resources/src/grails/templates/scaffolding/index.gsp (No such file or directory)
      Message: /Users/pledbrook/dev/tools/grails-core/grails-resources/src/grails/templates/scaffolding/index.gsp (No such file or directory)
         Line | Method
      ->> 120 | <init>  in java.io.FileInputStream
      - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 
      |   886 | runTask in java.util.concurrent.ThreadPoolExecutor$Worker
      |   908 | run . . in     ''
      ^   680 | run     in java.lang.Thread
      

      To reproduce, just grab the grails2 branch of the project and run it (I do it inside interactive console, but that shouldn't have an impact). Hitting the above URL should result in the stack trace reported.

        Activity

        Graeme Rocher added a comment -

        Would help if you could provide a link to the Pomodoro project source code (Github I assume?)

        Peter Ledbrook added a comment -

        Sorry, I was too clever. The 'grails-pomodoro' text is a link to the project on GitHub.

        Graeme Rocher added a comment -

        Ah silly me, didn't see it. Thanks.. looking

        Klaus Baumgartner added a comment -

        Any news on this?

        Graeme Rocher added a comment -

        The issue is fixed and will be available in 2.0.1


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Peter Ledbrook
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development