Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build System, Scaffolding
    • Labels:
    • Environment:
      Ubuntu Mint

      Description

      Dear Grails team,

      recently, I am involved in creating a restful Grails project.
      To make the development more agile, we created a controller, a service and a domain with their respective tests, that work perfectly.

      As the code is very similar to other domains, I ran the script of Grails 'install-templates'. More or less it meets all my expectations.
      The problem I have seen is that I need more variables than provided the 'artifact' by default (adds the @artifact.name@ but I need to add more ...)

      I modified the script: '_GrailsCreateArtifacts.groovy', but I find it somewhat annoying to have to make sure that all team members have to replace the existing file 'springsource/grails-2.0.1/_GrailsCreateArtifacts.groovy' with the modified file ...

      Is there any way to tell grails to execute the modified file if found in the project (for example in the folder 'scripts') instead of the one in the system? Can you suggest another way to include these variables?

      Also I found something strange that the variables that can be used are different depending on whether the template is within the "scaffolding" or not ... What is the reason for this?

      Thank you very much

        Activity

        jagiro created issue -
        Graeme Rocher added a comment -

        please ask usage questions on the mailing list. JIRA is for bug reports only

        Graeme Rocher made changes -
        Field Original Value New Value
        Resolution Not A Bug [ 6 ]
        Status Open [ 1 ] Closed [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            jagiro
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development