Grails
  1. Grails
  2. GRAILS-9406

Mavenized project tries to pull in Groovy 1.7.8

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.1.2, 2.2-RC1
    • Component/s: None
    • Labels:
      None

      Description

      This is a problem with maven integration. Reproduce like this:

      1. create archetype:
        mvn archetype:generate -DarchetypeGroupId=org.grails -DarchetypeArtifactId=grails-maven-archetype -DarchetypeVersion=${grailsVersion} -DgroupId=example -DartifactId=proj -DarchetypeRepository=http://repo.grails.org/grails/core/
        
      2. edit pom.xml to use 2.1.1 and Java 1.6
      3. mvn compile and error happens:
        Fatal error during compilation org.apache.tools.ant.BuildException: BUG! exception in phase 'class generation' in source unit '/Users/andrew/NonEclipse/Maven/projects/ggts/plugins/resources-1.1.6/grails-app/taglib/org/grails/plugin/resource/ResourceTagLib.groovy' ClassNode#getTypeClass for java.io.Writer is called before the type class is set  (Use --stacktrace to see the full trace)

      Looks like problem comes because of the following dependency hierarchy:

      • grails-plugin-testing 2.1.1 pulls in
      • grails-datastore-gorm 1.1.0.RELEASE pulls in
      • grails-test 1.3.7 pulls in
      • groovy-all 1.7.8

      Explicitly adding a 1.8.8 dependency on groovy-all and the problem goes away.

        Activity

        Andrew Eisenberg added a comment -

        Do you have a link to the commit for the fix?

        Burt Beckwith added a comment -

        The commits are listed in the Git Commits tab

        Andrew Eisenberg added a comment -

        Thanks. Didn't notice that tab.


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Andrew Eisenberg
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development