Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.2
    • Labels:
      None
    • Environment:
      Mac OSX 10.8.x
      JDK 7

      Description

      It looks like the plugin has dependencies to the classes.jar included with JDK6.
      This file does not exist anymore in JDK 7.

      <profile>
      <id>jdk_mac</id>
      <activation>
      <os>
      <family>mac</family>
      </os>
      </activation>
      <dependencies>
      <dependency>
      <groupId>com.sun</groupId>
      <artifactId>tools</artifactId>
      <version>1.6</version>
      <scope>system</scope>
      <systemPath>$

      {java.home}

      /bundle/Classes/classes.jar</systemPath>
      </dependency>
      </dependencies>
      </profile>

      A mvn build throws the following exception:

      $ mvn clean install
      [INFO] Scanning for projects...
      [ERROR] The build could not read 1 project -> [Help 1]
      [ERROR]
      [ERROR] The project be.ixor:doccle-euui:0.2-SNAPSHOT (/Users/ct/Projects/ixor/doccle/pom.xml) has 2 errors
      [ERROR] Unresolveable build extension: Plugin org.grails:grails-maven-plugin:2.1.0 or one of its dependencies could not be resolved: Could not find artifact com.sun:tools:jar:1.6 at specified path /Library/Java/JavaVirtualMachines/jdk1.7.0_07.jdk/Contents/Home/jre/bundle/Classes/classes.jar -> [Help 2]
      [ERROR] Unknown packaging: grails-app @ line 9, column 16
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
      [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException

        Activity

        Manuel added a comment -

        Same problem here with 2.1.3.
        Apparently the problem is not fixed

        Manuel added a comment -

        My environment is Windows 7, I forgot to say

        David Carr added a comment -

        Due to merge problems, the Mac fix didn't make it into 2.2.0, but it should work on Mac in 2.1.2 and later, and hopefully 2.2.1 and later. The pull request have comments explaining what happened with the merge.

        David Carr added a comment -

        Manuel, you may be dealing with a different issue. The issue above was a Mac-specific problem, as far as I know.

        Mathias Lin added a comment -

        I'm also still having the issue on Mac OS X 10.7.4, Maven 3.0.3, Grails 2.2.0.


          People

          • Assignee:
            Graeme Rocher
            Reporter:
            Christian Tytgat
          • Votes:
            6 Vote for this issue
            Watchers:
            12 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: