Uploaded image for project: 'Grails'
  1. Grails
  2. GRAILS-10941

CTRL + C in cmd window does not stop running app Win 7 64 v 2.3.4

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.4
    • Fix Version/s: 2.3.5
    • Component/s: None
    • Labels:
      None
    • Environment:
      Win 7 Home 64; grails 2.3.4; Java: 1.7.0_02; groovy 2.2.1

      Description

      Just downloaded 2.3.4 and built a simple app. I am unable to stop the app with CTRL+C. I am able to do so with my previous grails version - 2.2.1. The same issue with almost identical configuration reported at stackoverflow:
      http://stackoverflow.com/questions/20687578/how-to-terminate-grails-2-3-application-started-with-run-app

      Let me know if any other information is needed. Thanks!

        Issue Links

          Activity

          Boyko Todorov added a comment -

          bug report

          Rico Krasowski added a comment -
          Graeme Rocher added a comment -

          Thanks

          Boyko Todorov added a comment -

          Just downloaded 2.3.5, but still unable to kill the running app with CTRL+C. Also, when I run stop-app from a different window, there is no indication the app was stopped in the ..."run-app" window.

          Albert Bupp added a comment -

          This problem is definitely not fixed in Grails v2.3.5.

          Albert Bupp added a comment -

          This problem appears to be fixed in Grails v2.3.6.

          Boyko Todorov added a comment -

          Yep, just pulled down 2.3.7 and it works! Thanks!

          Alexander Chernyakevich added a comment -

          Problem is not resolved completely, just partially - now Grails just stop the process linked to console. But in reality if you have forked mode of Grails on (by default it is on) then second JVM process still continue to work. As result you will get HTTP port used by that process and you will not be able to run grails run-app again until you will manually kill that process.

          See GRAILS-11119 for more details.

          Boyko Todorov added a comment -

          Just pulled down 2.4 and confirmed Alexander's comment - CTRL-C seems to kill the process in the console, but when I do run-app after that, I am unable to due to the java tomcat process still running and using port 8080.


            People

            • Assignee:
              Graeme Rocher
              Reporter:
              Boyko Todorov
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: